Commit f1c697fd authored by mjg226's avatar mjg226
Browse files

updated defintions to utilise openCL version number and not just check for 1.1...

updated defintions to utilise openCL version number and not just check for 1.1 or 1.2, but version number atleast 1.1
updated version number of API due to change.
parent c63b0a80
......@@ -38,7 +38,9 @@ THE SOFTWARE.
#pragma OPENCL EXTENSION cl_khr_fp64 : enable
#endif
#if !(defined(CL_VERSION_1_1) || defined(CL_VERSION_1_2))
//#if !(defined(CL_VERSION_1_1) || defined(CL_VERSION_1_2))
#if !(defined(__OPENCL_C_VERSION__) && __OPENCL_C_VERSION__ >= 110)
#error "At least openCL version 1.1 needed".
#endif
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment